Forum Thread: I am trying to get the file from the Towelroot site, but it will not download on my phone (Samsung Galaxy S3 i747m)

Get the Gadget Hacks Daily

Life hacks for your smartphone.

6 Responses

i suggest you use the brownser that comes with the phone. somehow google is not allowing it to download the file the apk to root.

ty Armel

yes I was using Chrome. As you suggested the browser that came with the phone did work. I am just waiting on my download.

OK I could not get the file to download altho' it did try on the phone.

So I downloaded it to my PC and then transferred it to my phone. It went thru the process, right up until the 'Make it Rain' page. When I clicked on it I got a msg that said "This phone isn't currently supported."

The phone is a Samsung Galaxy S3 SGH-i747M s/n: R21D47LM7KT
running Android version 4.4.2, with kernel version 3.4.0-1784548
I did read thru the comments and did not see anything about rooting not working on this phone. Did I miss something?

no actually you did not. it probably does not support samsung galaxy s3 but here is how you can root and i have tried it works. i am posting the link below just download it run it follow the instructions and you should be just fine. http://www.kingoapp.com/

i suggest you use android root dude. It supports samsung galaxy lines like Samsung S3 1737m. i tried to it many times works very good. heres the link if your interested: https://www.androidroot.us.com/

Share Your Thoughts

  • Hot
  • Active